buggLite Middleware - Bugs: bug #49763, Packaging problem with .pyc files...

 
 
Show feedback again

You are not allowed to post comments on this tracker with your current authentication level.

bug #49763: Packaging problem with .pyc files from glite-wms-ui-api-python-3.2.2-0.sl5

Submitted by:  Andrew Elwell <aelwell>
Submitted on:  2009-04-29 11:26  
 
Status: Ready for ReviewOpen/Closed: Closed
Category: WMSSeverity: 4 - Normal
Baseline Release (where bug has been observed): gLite 3.2Release (where bug fix will be available: EMI 1, EMI 2, EMI 3, All): EMI1
OS: SL 5Architecture: x86_64
Bug detection area: CertificationAssigned to: None
Privacy: PublicPriority: Medium
Associated Test: None
GGUS reference URL: 
Component tag(s): 
Subsystem tag(s): 
Build environment: None

2012-06-28 13:53, comment #2:

the byte compiled files SHOULD be packaged or you'll get SELinux errors when they are created

see http://fedoraproject.org/wiki/Packa...

Andrew Elwell <aelwell>
Project Administrator
2009-04-29 16:47, comment #1:

hi all,
*.pyc files are only created at runtime, so there's no need at all to package them, I wonder why they are included.
I'll have a look at etics packaging and try to figure out where is the problem and how to solve it.

cheers,
Alessandro

Alessandro Maraschini <maraska>
2009-04-29 11:26, original submission:

packaging problem with glite-wms-ui-api-python

It has created empty .pyc files - these should be the byte compiled ones

[aelwell@vtb-generic-102 ~]$ rpm -qlv glite-wms-ui-api-python-3.2.2-0.sl5 | grep pyc
-rwxr-xr-x 1 root root 0 Apr 7 12:09 /opt/glite/lib64/python/glite_wmsui_AdWrapper.pyc
-rwxr-xr-x 1 root root 0 Apr 7 12:09 /opt/glite/lib64/python/glite_wmsui_LbWrapper.pyc
-rwxr-xr-x 1 root root 0 Apr 7 12:09 /opt/glite/lib64/python/glite_wmsui_LogWrapper.pyc
-rwxr-xr-x 1 root root 0 Apr 7 12:09 /opt/glite/lib64/python/glite_wmsui_SdWrapper.pyc
-rwxr-xr-x 1 root root 0 Apr 7 12:09 /opt/glite/lib64/python/glite_wmsui_UcWrapper.pyc
-rwxr-xr-x 1 root root 0 Apr 7 12:09 /opt/glite/lib64/python/wmsui_api.pyc
-rwxr-xr-x 1 root root 0 Apr 7 12:09 /opt/glite/lib64/python/wmsui_checks.pyc
-rwxr-xr-x 1 root root 0 Apr 7 12:09 /opt/glite/lib64/python/wmsui_listener.pyc
-rwxr-xr-x 1 root root 0 Apr 7 12:09 /opt/glite/lib64/python/wmsui_utils.pyc

Andrew Elwell <aelwell>
Project Administrator

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by mcecchi (Updated the item)
  • -unavailable- added by maraska (Posted a comment)
  • -unavailable- added by aelwell (Submitted the item)
  •  

     

     

    Follow 8 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    2012-06-28 11:49mcecchiStatusAccepted=>Ready for Review
      Release (where bug fix will be available: EMI 1, EMI 2, EMI 3, All)=>EMI1
      Assigned tomaraska=>None
      Open/Closed-Automatic update due to transitions settings-=>Closed
    2009-04-29 16:47maraskaStatusNone=>Accepted
      Assigned tomcecchi=>maraska
    2009-04-29 11:26aelwellSummaryPackaging problem with .pyc files from =>Packaging problem with .pyc files from glite-wms-ui-api-python-3.2.2-0.sl5
    2009-04-29 11:26aelwellAssigned to-Automatic update due to transitions settings-=>mcecchi
    Show feedback again

    Back to the top


    Powered by Savane SVN (toward 3.1)