buggLite Middleware - Bugs: bug #30654, Debug mode for glite-wms-* could...

 
 
Show feedback again

You are not allowed to post comments on this tracker with your current authentication level.

bug #30654: Debug mode for glite-wms-* could print used configuration file.

Submitted by:  Steve Traylen <straylen>
Submitted on:  2007-10-23 12:02  
 
Status: Ready for ReviewOpen/Closed: Closed
Category: WMSSeverity: 2 - Cosmetic
Baseline Release (where bug has been observed): gLite 3.1Release (where bug fix will be available: EMI 1, EMI 2, EMI 3, All): EMI1
OS: SL 4Architecture: i386
Bug detection area: ProductionAssigned to: None
Privacy: PublicPriority: Medium
Associated Test: None
GGUS reference URL: 
Component tag(s): 
Subsystem tag(s): 
Build environment: None

(Jump to the original submission Jump to the original submission)

2008-05-27 12:39, comment #8:

Hi Luca,

Okay , not a problem, it has only ever been cosmetic.
Just trying to clean up my savannah entries.
Steve

Steve Traylen <straylen>
2008-05-27 12:09, comment #7:

Hi Steve,
Sadly, not. The restructuring branch release date is still to be set, and I cannot assure when the patched version will be in production.

Cheers,
Luca

Luca Petronzio <lpetronz>
2008-05-27 12:00, comment #6:

Is this fixed in a released or upcoming WMS patch now?

Steve

Steve Traylen <straylen>
2008-03-13 15:39, comment #5:

The fix will be provided in the Restructuring branch

Alessandro Maraschini <maraska>
2007-10-24 11:58, comment #4:

Hi Steve,
As you pointed out this is an undesired behavior, the informations displayed at runtime should match as much as possible with the informations printed into the log file.
The bug will be now solved, the fix will be available from the next gLite release.
Cheers,
Luca

Luca Petronzio <lpetronz>
2007-10-23 14:39, comment #3:

Luca,

Thanks for the prompt reply.

I had made the wrong assumption that the debug file was
the same as the console output, that does seem to be the case.

$ glite-wms-job-list-match --debug \
-a helloworld.jdl 2>&1 | tee out.txt

and consequently:

$ grep -A 2 -B 2 glite_wms.conf out.txt-----------------------------------------23 Oct 2007, 14:28:46 -I- PID: 24853 (Debug) - Loaded Vo specific configuration file: /opt/glite/etc/dteam/glite_wms.conf-----------------------------------------

but

$ grep glite_wms.conf /tmp/glite-wms-job-list-match_16568_24853_20071023_14-28-46.log

produces nothing.

Entirely up to you if you want to do something with this:

To me anyway the message.

*** Log file created ***Possible Errors and Debug messages have been printed in the following file:/tmp/glite-wms-job-list-match_16568_24853_20071023_14-28-46.log

suggested this was the place to look for debug information
but in fact rather more goes to the console.

Steve

Steve Traylen <straylen>
2007-10-23 14:18, comment #2:

Hello Steve,
In the debug mode the configuration file is actually displayed, together with its location(s).
Here's an example:

[trinity] /share/luca/Repository/branch > glite-wms-job-list-match -a --debug ls.jdl
-----------------------------------------
23 Oct 2007, 14:16:31 -I- PID: 13441 (Debug) - Vo read from proxy certificate extension
-----------------------------------------
-----------------------------------------
23 Oct 2007, 14:16:31 -I- PID: 13441 (Debug) - VirtualOrganisation value : infngrid
-----------------------------------------
-----------------------------------------
23 Oct 2007, 14:16:31 -I- PID: 13441 (Debug) - Loaded generic configuration file:
/share/luca/Repository/branch///stage//etc/glite_wms.conf
-----------------------------------------
-----------------------------------------
23 Oct 2007, 14:16:31 -I- PID: 13441 (Debug) - Loaded Vo specific configuration file:
/share/luca/Repository/branch///stage//etc/infngrid/glite_wmsclient.conf
-----------------------------------------
-----------------------------------------
23 Oct 2007, 14:16:31 -I- PID: 13441 (Debug) - Loaded user configuration file:
/home/luca/.glite/infngrid/glite_wmsclient.conf
-----------------------------------------
-----------------------------------------
23 Oct 2007, 14:16:31 -I- PID: 13441 (Debug) - Loaded Configuration values:
[
requirements = other.GlueCEStateStatus == "Production";
DelegationId = "luca";
RetryCount = 3;
ListenerStorage = "${GLITE_LOCATION_TMP}";
WMProxyEndPoints = { "https://ghemon.cnaf.infn.it:7443/gl...","https://tigerman.cnaf.infn.it:7443/..." };
MyProxyServer = "kuiken.nikhef.nl";
OutputStorage = "/tmp";
virtualorganisation = "egee";
ShallowRetryCount = 3;
LBServiceDiscoveryType = "org.glite.lb.server";
JdlDefaultAttributes =
[
requirements = other.GlueCEStateStatus == "Production";
RetryCount = 3;
VirtualOrganisation = "infngrid";
rank = -other.GlueCEStateEstimatedResponseTime
];
LBAddress = "ghemon.cnaf.infn.it:9000";
WMProxyServiceDiscoveryType = "org.glite.wms.wmproxy";
ErrorStorage = "${GLITE_LOCATION_LOG}"
]
-----------------------------------------
-----------------------------------------
23 Oct 2007, 14:16:31 -I- PID: 13441 (Debug) - Auto-Generation of the Delegation Identifier: z4gL7hO49UUONyG3jCwr-w
-----------------------------------------
-----------------------------------------
23 Oct 2007, 14:16:31 -I- PID: 13441 (Debug) - Delegation ID automatically generated
-----------------------------------------
-----------------------------------------
23 Oct 2007, 14:16:31 -I- PID: 13441 (Debug) - Getting Endpoint URL from configuration file
-----------------------------------------

I would set this bug as invalid if you don't mind.
Cheers,
Luca

Luca Petronzio <lpetronz>
2007-10-23 13:36, comment #1:

correction for me, the man page does detail the location
of the configuration file used.

Steve Traylen <straylen>
2007-10-23 12:02, original submission:

Hi,

$ rpm -qf /opt/glite/bin/glite-wms-job-list-match glite-wms-client-3.1.11-4.slc4

$ glite-wms-job-list-match --debug -a helloworld.jdl

produces a lot of information including:

"Getting Endpoint URL from configuration file"

it would be helpful if the configuration file that was used
was reported as well.

On a similar note neither

$ glite-wms-job-list-match -h
nor
$ man glite-wms-job-list-match

specify what the default configuration file location is.

Steve

Steve Traylen <straylen>

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by mcecchi (Updated the item)
  • -unavailable- added by maraska (Posted a comment)
  • -unavailable- added by straylen (Submitted the item)
  •  

     

     

    Follow 12 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    2012-06-28 11:17mcecchiStatusRemind=>Ready for Review
      Release (where bug fix will be available: EMI 1, EMI 2, EMI 3, All)=>EMI1
      Assigned tolpetronz=>None
      Open/Closed-Automatic update due to transitions settings-=>Closed
    2008-09-03 12:03maraskaStatusNone=>Remind
    2008-09-03 12:03maraskaStatusAccepted=>None
    2008-03-13 15:39maraskaStatusIn progress=>Accepted
      Severity1 - Enhancement=>2 - Cosmetic
    2007-10-24 11:59lpetronzStatusAccepted=>In progress
    2007-10-24 11:58lpetronzStatusNone=>Accepted
      Assigned toguarise=>lpetronz
    2007-10-23 12:02straylenAssigned to-Automatic update due to transitions settings-=>guarise
    Show feedback again

    Back to the top


    Powered by Savane SVN (toward 3.1)